パスワードを忘れた? アカウント作成
13382234 story
Firefox

Firefox、64ビットWindows環境では64ビット版のインストールがデフォルトに 22

ストーリー by hylom
ついに 部門より
headless曰く、

Mozillaは14日、64ビットWindows環境にFirefoxをインストールする際、デフォルトで64ビット版のFirefoxがインストールされるようになったと発表した(The Firefox FrontierNeowinBetaNews)。

64ビット版のFirefoxを使用することで、32ビット版よりもセキュリティが向上し、クラッシュ発生率は低下する。Firefox 53以降では64ビットWindows環境でStubインストーラーを実行すると32ビット版/64ビット版を選択可能となっていたが、デフォルトでは32ビット版が選択されていた。

現在64ビットWindows環境で32ビット版のFirefoxを使用しているユーザーは、Firefoxを再インストールすることで64ビット版のFirefoxへ移行できる。また、Mozillaは今後のリリースで64ビット版WindowsユーザーのFirefoxをすべて64ビット版に移行する計画だという。そのため、待っていればいずれ64ビット版に自動で移行されることになる。その後も32ビット版を使い続けたいユーザーは、32ビット版のインストーラーを実行すればよいとのことだ。

この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。
  • by Anonymous Coward on 2017年08月17日 15時33分 (#3262567)

    詳しい人いますか?

    あ、でも確かに32Bit版のほうが早いんだから入れる価値ないという時代もあった気がした

    • 概ねそゆことだったみたいです。関連ストーリーの中でも書かれています。
      消極的な理由。64ビットのメリットが見いだせず、ユーザが少ない中で(これは卵が先か鶏が先かだけど)不足している開発リソースはあてられないという話だった。ただ、大量にタブを開く用途では効果があることが2012年当時の実装でも確認されていて、Nightlyは残されることとなりました [it.srad.jp]。

      個人的には当時から64ビットのNightlyを使い続けていますが、片手から両手で数えられる程度のエクステンションとFlashプラグインで使う程度なら、全然普通に使えていました。だから、そもそもNightlyが残った理由にも示されるように、当時から強引に64ビットに舵を切ることもできたんじゃないかなと思います。しかし首脳(?)は多くのFirefoxユーザは完璧な互換性の継続を求めると考えたんじゃないでしょうかね。これもあくまで私見だけど、この判断は正しかったんじゃないかなぁ。その後、WebExtensionsに全面切り替えするという決定は、当時の判断を悪いものに見せちゃいますけど。

      親コメント
    • 大体Flash Playerのせい。

      半分冗談ですけどね。
      # Javaのせいかもしれない。

      親コメント
      • by Anonymous Coward

        Unityのせいで32bit使っていた時期もありました。

        # Flashの置き換えだの威勢が良かった割にこういうところおざなりなのはどうかと思った

    • by Anonymous Coward on 2017年08月17日 15時54分 (#3262587)

      詳しくないけど、32bitでしか動かないプラグインや拡張があったが
      NPAPIを切り捨て過去のしがらみから解放されたからではないかな。
      マルチプロセス機能の導入でも動かなくなる拡張が出るし拡張多く入れている人は大変だね

      親コメント
      • by Anonymous Coward

        そういや57からWebExtensions方式にしてそれ以前の拡張は切り捨てるね。

        #個人的にはtabmixplus(WebExtensionsじゃ全機能の移植が事実上不可能?)と
        #艦これタイマー(開発終了)が使えなくなると
        #Firefoxをメインにする理由がなくなる

      • by Anonymous Coward

        JREやAdobe ReaderのWebブラウザ用プラグインが64bit非対応ですね。
        >重要: Firefox 52 ESR の Windows 64 ビット版は、Adobe Flash と Microsoft Silverlight プラグインのみをサポートしています。
        >Java や他のプラグインのサポートが必要な場合は、Windows (32-bit) のダウンロードを選択してください。
        https://support.mozilla.org/ja/kb/npapi-plugins [mozilla.org]

        一年ほど前の話ですが…
        64bit版のFirefoxにこれらのプラグインが読み込まれないので
        プラグイン自体が(Flash Playerを除いて)廃止になったのかと思

  • by Anonymous Coward on 2017年08月17日 16時20分 (#3262603)

    メンテするひとが居ねえという事情で、Dailyでしか手に入らないのは辛い……

    # おめえが手を上げろというのは無しで!Cowardゆえ

    • by Anonymous Coward

      Webとサポートの切れたポンコツを除けば、OutlookとThunderbirdしかないのにパッとしないよね。
      http://news.mynavi.jp/news/2017/08/16/165/ [mynavi.jp]

      • Sylpheed…

        親コメント
      • by Anonymous Coward on 2017年08月17日 16時59分 (#3262642)

        「え?E-mailってパソコンでも読めるんですか?!」と言った若いもんがいるとかいないとか。

        E-mail読むのにケータイやブラウザじゃなくメーラーを使うのは、
        ナウいヤングらからはオッサン扱いされてるかもしれんぞ。

        親コメント
        • by Anonymous Coward

          「え?E-mailってパソコンでも読めるんですか?!」と言った若いもんがいるとかいないとか。

          SMSと勘違いしてる可能性があるんではないかと……

          SMSですか?見れますよ、そうiPhonemacOSとiMessageならね
          # 若いもん「パソコンじゃない!」というお叱りがありそうです

          • 二段階認証は良くSMS使うので、あれは微妙に便利。

            親コメント
          • ところがiOS11 beta5(public betaではbeta4)以降、iMessageのiCloud同期はなくなっているんだよね。(macOS High Sierraも恐らく同時リリースしたbuildから無くなっている筈)
            復活するにしても11.1とか11.2とかになりそうな空気感。
            --
            # rm -rf ./.
            親コメント
            • by Anonymous Coward

              それは、新機能であるiMessage to Cloudのことでしょ。
              おそらくあれは、サーバーにバックアップを置いて、ローカルから削除しても、後で復活できる、みたいな機能じゃないかな。
              現状でも、普通にしばらく起動してないMacのMessageひらけば、バババっとメッセージが同期されてきますよ。
              サーバーに一時的にプールされてたものなのか、他の端末からリレーされてきたのかはわからないが。

          • by Anonymous Coward

            >SMSと勘違いしてる可能性があるんではないかと……
            それはそれで興味深い間違いだと思う。
            #「GooはGoogleのパクリだと思ってました」みたいな感じで

            知らないならまだしも、いまどきE-mailを使ってない若者って一体。

      • 一応UWPのメールアプリも、その、無いことも無く。一応GmailとかOutlook.comとか対応してるし。
        なんか使い方が全然分からないけど。微妙にゴソッと機能が欠落してる気もするし。
        macOSのメールアプリ程度でいいので、もう少し作り込んで欲しいな。

        親コメント
      • by Anonymous Coward

        秀丸メールやShurikenも悪くないと思うけど、
        いまどき新たに有料メーラーに手を出す人はいないよなぁ

        • by Anonymous Coward

          一回払っちゃえば常に最新版が使えるわけで・・・
          秀丸とBeckyを昔から愛用しております

          まあ秀丸はエディタ買ったら付いてきたんですけどね

        • by Anonymous Coward

          無料ならSylpheedとか電信8号とかedmaxフリー版とかあるにはあるんだけど知名度がねぇ

          • by Anonymous Coward

            Googleカレンダーと連携とりたくて、BeckyからThunderbirdに乗り換えたのですが、ThunderbirdとOutlook.comのimapとの相性が悪いみたいなので、さらに別の乗り換え先を探しています。
            有料のSylpheed proがよさそうと思ったのですが、Googleカレンダーと連携ができなくなった状態で、一年半放置されている様で乗り換えるわけにもいかず。
            何か良い乗り換え先はありませんでしょうか?

            • by Anonymous Coward

              英語版しかないですが、eM Clientオススメです。Outlook.comは試してないのでわかりませんが、Gmail、Googleカレンダーの連携はばっちり
              http://emclient.com/ [emclient.com]

typodupeerror

一つのことを行い、またそれをうまくやるプログラムを書け -- Malcolm Douglas McIlroy

読み込み中...